Skip to main content
Jump to: navigation, search

Difference between revisions of "Component Request (Buckminster)"

m (Buckminster Component Request moved to Component Request (Buckminster))
 
(One intermediate revision by one other user not shown)
Line 14: Line 14:
  
 
==Category==
 
==Category==
{{:Buckminster Component Category}}
 
  
 
==Version Designator==
 
==Version Designator==
{{:Buckminster Version Designator}}
 
  
 
==Version Type==
 
==Version Type==
Line 29: Line 27:
  
 
This is a request for the "Foobar" component of any version larger or equal to version 1.0.0, and smaller or equal to 3.2.1. The OSGiVersionType is supplied with Buckminster and understands a standard numbering scheme. See [[Buckminster Version Type|Version Type]] for more information.
 
This is a request for the "Foobar" component of any version larger or equal to version 1.0.0, and smaller or equal to 3.2.1. The OSGiVersionType is supplied with Buckminster and understands a standard numbering scheme. See [[Buckminster Version Type|Version Type]] for more information.
[[Category:Buckminster]]
+
 
[[Category:Buckminster Documentation]]
+
[[Category:Archived Buckminster Documentation]]
[[Category:Buckminster Key Concepts]]
+
 
<noinclude>
 
<noinclude>

Latest revision as of 10:03, 18 January 2008

< To: Buckminster Project

Component Request

A Component Request is a pointer that specifies a component by name, category, and suitable version(s) of that component.

A component request consists of:

  • name, the name of the component
  • category, the category that the component is a member of
  • VersionDesignator, i.e. a reference to a version, or range of versions
  • VersionType, a reference to a class that can understand the VersionDesignator string.

Name

The name of the wanted component.

Category

Version Designator

Version Type

A Version Type is a class that is used to parse and understand a plain version; "a pointer to a specific version". More specifically, a Version Type will be asked to parse and compare the text between the delimiters in a Version Designator.

In the request you must supply the name of the Version Type that understands the plain version strings you have used in the version designator.

Example

Name: Foobar
VersionDesignator: [1.0.0,3.2.1]
VersionType: OSGiVersionType

This is a request for the "Foobar" component of any version larger or equal to version 1.0.0, and smaller or equal to 3.2.1. The OSGiVersionType is supplied with Buckminster and understands a standard numbering scheme. See Version Type for more information.

Copyright © Eclipse Foundation, Inc. All Rights Reserved.