Jump to: navigation, search

Difference between revisions of "CDT/StandaloneDebugger"

< CDT
(How to try it out)
(How to try it out)
Line 6: Line 6:
 
== How to try it out ==
 
== How to try it out ==
  
# Download the CPP EPP Luna M7 product
+
# Download the IDE for C/C++ Developers Luna M7 product tar file
 
#* https://www.eclipse.org/downloads/index-developer.php
 
#* https://www.eclipse.org/downloads/index-developer.php
# Untar the CPP EPP to a local directory
+
# Untar the C/C++ IDE into a local directory (let's call this $CPP_LUNA_M7_DIR)
 
# cd $CPP_LUNA_M7_DIR/eclipse/plugins/org.eclipse.cdt.debug.application_1.0.0.201405061918/scripts
 
# cd $CPP_LUNA_M7_DIR/eclipse/plugins/org.eclipse.cdt.debug.application_1.0.0.201405061918/scripts
# Run the command
+
# Run the command:
 
#* sh ./install.sh
 
#* sh ./install.sh
#* this will create the directory: $HOME/cdtdebugger for you
+
#* this will create the directory: $HOME/cdtdebugger for you and fill it appropriately
 
# To run the debugger:
 
# To run the debugger:
 
#* $HOME/cdtdebugger/cdtdebug [-data workspace] [-consoleLog] -a | [-b build_log_location] [-c core_file_location] [-e executable_path] [arg1 ... argn]
 
#* $HOME/cdtdebugger/cdtdebug [-data workspace] [-consoleLog] -a | [-b build_log_location] [-c core_file_location] [-e executable_path] [arg1 ... argn]
Line 18: Line 18:
 
#* if you run with no arguments, it will debug the same executable you ran the last time
 
#* if you run with no arguments, it will debug the same executable you ran the last time
 
#* id you specify a core file, you must also specify an executable
 
#* id you specify a core file, you must also specify an executable
 +
#* the cdtdebug command can be moved from $HOME/cdtdebugger if you wish
  
 
== Status ==
 
== Status ==

Revision as of 14:18, 9 May 2014

This page details the effort to create a stand-alone Debugger using Eclipse.

StandaloneDebuggerScreenshot.png


How to try it out

  1. Download the IDE for C/C++ Developers Luna M7 product tar file
  2. Untar the C/C++ IDE into a local directory (let's call this $CPP_LUNA_M7_DIR)
  3. cd $CPP_LUNA_M7_DIR/eclipse/plugins/org.eclipse.cdt.debug.application_1.0.0.201405061918/scripts
  4. Run the command:
    • sh ./install.sh
    • this will create the directory: $HOME/cdtdebugger for you and fill it appropriately
  5. To run the debugger:
    • $HOME/cdtdebugger/cdtdebug [-data workspace] [-consoleLog] -a | [-b build_log_location] [-c core_file_location] [-e executable_path] [arg1 ... argn]
    • this will default to workspace-gdbstandalone if you do not specifiy a workspace via the -data option
    • if you run with no arguments, it will debug the same executable you ran the last time
    • id you specify a core file, you must also specify an executable
    • the cdtdebug command can be moved from $HOME/cdtdebugger if you wish

Status

Sept 17, 2013

  • first pass at standalone GDB debugger using CDT components
  • using Eclipse application and restricting plug-ins used
  • debugger is working but indexer is not being invoked
  • header files not being recognized

Sept 23, 2013

  • added default GCC spec file LanguageSettingsProvider
  • this gets standard header files to open in Outline view

Sept 30, 2013

  • added code to add all source files specified as Project resources
  • this gets indexer to work and adds non-C-standard header file support

Oct 07, 2013

  • Removed Source and Refactoring menus using IActivity filters

Oct 14, 2013

  • added support for reading .debug_macro section to find command-line flags
    • currently not being picked up by indexer for header files

Oct 21, 2013

  • added Dwarf4 support to CDT
    • code submitted upstream for review
  • solved issue with indexer using data discovered from .debug_macro
    • command line macros now discovered from modules compiled with -g3

Oct 28, 2013

  • changed code to clean-up if an executable is specified
    • running again with no executable specified will use the last launch
  • added support for specifying build console
    • build console is parsed for flags and include path settings

Nov 18, 2013

  • added progress dialog
  • added support for running via command-line script
    • fixed program argument parsing
    • figured out what minimally is needed to reuse repository
  • fixed some warnings and errors

Dec 20, 2013

  • added gdbstandalone.zip to run from command line with Luna M4 CPP EPP
  • added default jar to use with Eclipse Luna M4 CPP EPP
  • completed GDBStandalone.product which contains icons
  • added check for invalid executable
    • special dialog brought up to fix executable location and enter arguments
  • fixed NPE issue when running debugger 2nd time on same workspace

Jan 15, 2014

  • added New Executable dialog off of File menu to allow specification of different executable to debug
  • added Help doc support, but no docs enabled as of yet
  • added Customize Perspective from Window menu to allow enablement of Reverse Debugging and C/C++ Tracepoint support

Jan 17, 2014

  • added Help menu which contains Help Contents, Search, Dynamic Help, and About Eclipse items

Feb 07, 2014

  • added User Guide which is transformed CDT guide
  • added mnemonics for menus
  • updated for Luna M5

May 09, 2014

  • Standalone debugger is part of Luna M7
  • shipped with C/C++ EPP for Luna M7
  • includes installation script to install locally
  • includes core-file debugging support
  • includes attach to executable debugging support