Skip to main content
Jump to: navigation, search

Difference between revisions of "CDO Source Installation"

 
(49 intermediate revisions by 3 users not shown)
Line 1: Line 1:
== Introduction ==
+
To provision the same development environment that the CDO developers use follow these simple steps:
This tutorial describes how to install the CDO workspace using [http://www.eclipse.org/buckminster/ Buckminster].<br>
+
The sources can also be browsed through the [http://git.eclipse.org/c/cdo/cdo.git/tree/ Git web interface].
+
  
== Prepare the IDE ==
+
# Download and start the [[Eclipse Installer]].
Download and install Eclipse 3.7 or 3.8 from [http://download.eclipse.org/eclipse/downloads/eclipse3x.php]
+
# Drag [https://git.eclipse.org/c/cdo/cdo.git/plain/releng/org.eclipse.emf.cdo.releng/CDOConfiguration.setup this link] and drop it on the installer's title area. Alternatively, copy the location of the previous link and apply it to the Eclipse Installer either via the menu in the upper right in simple mode or via the left-most toolbar button to the upper right in advanced mode.
 +
# Review and/or edit the variable values that the installer presents.
 +
# Click the Next/Finish buttons until the installation starts.
  
Then open a fresh development workspace.
 
  
[[Image:Cdo_source1.png]]
+
You can update your development workspace by pulling the latest updates into your CDO Git clone and selecting the '''Perform Setup Tasks...''' action in the '''Help''' menu.
 
+
 
+
Select the [http://download.eclipse.org/releases/indigo Indigo] (for 3.7) or [http://download.eclipse.org/releases/juno Juno] (for 3.8) p2 repository and install the following features:
+
* '''EMF - Eclipse Modeling Framework SDK'''
+
* '''Graphical Modeling Framework SDK''' (needed for CDO Dawn)
+
* '''Eclipse EGit''' (Team Provider)
+
 
+
Select the [http://download.eclipse.org/tools/buckminster/updates-3.7 Buckminster] p2 repository and install the following features:
+
* '''Buckminster - Core'''
+
* '''Buckminster - Git Support'''
+
* '''Buckminster - PDE Support'''
+
 
+
Now you have prepared your IDE with the required tools.
+
 
+
== Create the Target Platform ==
+
 
+
For the target platfrom first create an empty project called "_target".
+
 
+
[[Image:Cdo_install4.png]]
+
 
+
 
+
Now create an empty target definition that Buckminster later can fill with the needed plug-ins (Windows->Preferences->Plugin Development->Target Platform)
+
 
+
 
+
[[Image:Cdo_install5.png]]
+
 
+
 
+
Insert the name for the target platform.
+
 
+
[[Image:Cdo_install6.png]]
+
 
+
+
 
+
Click 'Add'.
+
 
+
[[Image:Cdo_install7.png]]
+
 
+
 
+
 
+
Add the directory location ${workspace_loc}/_target.
+
 
+
[[Image:Cdo_install8.png]]
+
 
+
 
+
Activate the platform.
+
 
+
[[Image:Cdo_install9.png]]
+
 
+
== Create the API Baseline ==
+
 
+
Now an API baseline will be created. Non-committers may skip this section.
+
 
+
* Create a new workspace project called "_baseline"
+
 
+
[[Image:Cdo_export_targetdef0.png]]
+
 
+
* Download the 4.0 baseline from [https://sourceforge.net/projects/net4j/files/Baselines/ SourceForge] and extract it into the _baseline project.
+
 
+
* Now add the API baseline: Open the <i>Preferences</i> (Window->Preferences) and open the "API Baselines" page.
+
 
+
[[Image:Cdo_export_targetdef3.png]]
+
 
+
* Click "Add Baseline...". Give it the name ''CDO 4.0 Baseline'' and choose the path to your ''_baseline'' project as destination. Then the API baseline is created and set active for your workspace.
+
 
+
[[Image:Cdo_export_targetdef4.png]]
+
 
+
== Bootstrap the Releng Project  ==
+
 
+
Now you need to checkout the releng project (Buckminster releng component). Download an appropriate Subversive Team Project Set file:
+
 
+
{| cellspacing="1" cellpadding="2" border="1" width="200"
+
|-
+
| <br>
+
| Users<br>
+
| Committers<br>
+
|-
+
| 4.1<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/trunk/plugins/org.eclipse.emf.cdo.releng/psf/bootstrap.psf Download]<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/trunk/plugins/org.eclipse.emf.cdo.releng/psf/bootstrap-committers.psf Download]<br>
+
|-
+
| 4.0<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/4.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap.psf Download]<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/4.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap-committers.psf Download]<br>
+
|-
+
| 3.0<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/3.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap.psf Download]<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/3.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap-committers.psf Download]<br>
+
|}
+
 
+
Select File->Import... and choose the Team Project Set import wizard. Select the downloaded bootstrap.psf
+
 
+
'''Hint:''' Instead of downloading the PSF-file, in Indigo you can copy the URL from the table above and import the Team Project Set directly from the copied URL.
+
 
+
[[Image:Cdo install10.png]]
+
 
+
[[Image:Cdo install11.png]]
+
 
+
[[Image:Cdo install12.png]]
+
 
+
<br>
+
 
+
== Materialize the Sources and the Target Platform ==
+
 
+
To materialize the sources right-click the local.mspec, select Buckminster|Import...
+
 
+
[[Image:Cdo_install15.png]]
+
 
+
While the following dialog is running go and fetch a coffee, or two, or three...
+
 
+
 
+
[[Image:Cdo_install16.png]]
+
 
+
Finally hit the 'Finish' button
+
 
+
[[Image:Cdo_install14.png]]
+
 
+
== Updating the Workspace ==
+
 
+
You can update your development workspace with re-importing the local.mpec as described above. Then the whole workspace and the target platform are updated.
+
 
+
Note, that re-importing doesn't update your source from the SVN repository. Use Subversive for this purpose!
+
 
+
== Tooling (Developers only) ==
+
 
+
Please do not forget to install install our versioning tool from [http://download.eclipse.org/modeling/emf/cdo/updates/integration http://download.eclipse.org/modeling/emf/cdo/updates/integration].
+
 
+
[[Image:CDO_Versioning_Tool.png]]
+

Latest revision as of 05:08, 2 February 2018

To provision the same development environment that the CDO developers use follow these simple steps:

  1. Download and start the Eclipse Installer.
  2. Drag this link and drop it on the installer's title area. Alternatively, copy the location of the previous link and apply it to the Eclipse Installer either via the menu in the upper right in simple mode or via the left-most toolbar button to the upper right in advanced mode.
  3. Review and/or edit the variable values that the installer presents.
  4. Click the Next/Finish buttons until the installation starts.


You can update your development workspace by pulling the latest updates into your CDO Git clone and selecting the Perform Setup Tasks... action in the Help menu.

Back to the top