Difference between revisions of "CDO Source Installation"

From Eclipsepedia

Jump to: navigation, search
(Tooling (Developers only))
(Prepare the IDE)
(45 intermediate revisions by 3 users not shown)
Line 1: Line 1:
== Introduction ==
+
This tutorial describes how to install a '''CDO workspace''' using [http://www.eclipse.org/buckminster/ Buckminster].<br>
This tutorial describes how to install the CDO workspace using [http://www.eclipse.org/buckminster/ Buckminster].<br>
+
The '''sources''' can also be browsed through [http://git.eclipse.org/c/cdo/cdo.git/tree http://git.eclipse.org/c/cdo/cdo.git/tree].<br>
The sources can also be browsed through the [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/ SVN web interface].
+
'''Binaries''' can be installed or downloaded from [http://www.eclipse.org/cdo/downloads http://www.eclipse.org/cdo/downloads].
  
 
== Prepare the IDE ==
 
== Prepare the IDE ==
Download and install Eclipse 3.7 from http://download.eclipse.org/eclipse/downloads
+
Download and install Eclipse 3.8 from [http://download.eclipse.org/eclipse/downloads/eclipse3x.php http://download.eclipse.org/eclipse/downloads/eclipse3x.php]
  
 
Then open a fresh development workspace.
 
Then open a fresh development workspace.
Line 11: Line 11:
  
  
Select the Indigo p2 repository:
+
Select the [http://download.eclipse.org/releases/juno Juno] (for 3.8) p2 repository and install the following features:
* http://download.eclipse.org/releases/indigo
+
* '''EMF - Eclipse Modeling Framework SDK'''
 +
* '''Graphical Modeling Framework (GMF) Notation SDK''' (needed for CDO Dawn)
 +
* '''Graphical Modeling Framework (GMF) Runtime SDK''' (needed for CDO Dawn)
 +
* '''Eclipse EGit'''
  
Install the following features:
+
Select the [http://download.eclipse.org/tools/buckminster/updates-4.2 Buckminster] p2 repository and install the following features:
* EMF - Eclipse Modeling Framework SDK
+
* '''Buckminster - Core'''
* Graphical Modeling Framework SDK (needed for CDO Dawn)
+
* '''Buckminster - Git Support'''
* Subversive SVN Team Provider (you'll be prompted to install a connector from Polarion when you first use Subversive to access a Subversion repository, we're happy with SVNkit 1.3.5)
+
* '''Buckminster - PDE Support'''
  
Note that, since Indigo, Buckminster no longer participates in the release train. Please install from:
+
Select the [http://download.eclipse.org/eclipse/updates/3.8 Eclipse Project Updates] p2 repository and install the following feature:
* http://download.eclipse.org/tools/buckminster/updates-3.7
+
* '''J2SE-1.5 Execution Environment Description'''
* http://download.cloudsmith.com/buckminster/external-3.7 (for headless support)
+
the following features
+
* Buckminster - Core
+
* Buckminster - Subversive Support
+
* Buckminster - PDE Support
+
  
 +
'''Committers''': Please do not forget to install our versioning tool from [http://download.eclipse.org/modeling/emf/cdo/updates/integration http://download.eclipse.org/modeling/emf/cdo/updates/integration]:
  
[[Image:Cdo_source2.png]]
+
[[Image:CDO_Versioning_Tool.png]]
 
+
[[Image:Cdo_install3.png]]
+
 
+
[[Image:Cdo_source4.png]]
+
 
+
[[Image:Cdo_source5.png]]
+
 
+
'''Hint:''' You may alternatively install from the buckminster update site. Subclipse support is available there. Add '''http://download.eclipse.org/tools/buckminster/updates-3.7''' to your update sites and select the required features.
+
 
+
'''Hint:''' If you have trouble with the subversive installation from the indigo update site (e.g. the adapters won't install) try using the subversive update site directly 
+
'''http://download.eclipse.org/technology/subversive/0.7/update-site/'''
+
  
 
Now you have prepared your IDE with the required tools.
 
Now you have prepared your IDE with the required tools.
 
== Create the Target Platform ==
 
 
For the target platfrom first create an empty project called "_target".
 
 
[[Image:Cdo_install4.png]]
 
 
 
Now create an empty target definition that Buckminster later can fill with the needed plug-ins (Windows->Preferences->Plugin Development->Target Platform)
 
 
 
[[Image:Cdo_install5.png]]
 
 
 
Insert the name for the target platform.
 
 
[[Image:Cdo_install6.png]]
 
 
 
 
Click 'Add'.
 
 
[[Image:Cdo_install7.png]]
 
 
 
 
Add the directory location ${workspace_loc}/_target.
 
 
[[Image:Cdo_install8.png]]
 
 
 
Activate the platform.
 
 
[[Image:Cdo_install9.png]]
 
  
 
== Create the API Baseline ==
 
== Create the API Baseline ==
  
Now an API baseline will be created. Non-committers may skip this section.
+
Non-committers may skip this section, but should instead reduce the problem marker severity for "Missing API baseline" from Error to Warning or Ignore (see screenshot below)!
  
* Create a new workspace project called "_baseline"
+
[[Image:APIBaseline-4.1-Ignore.png]]
  
[[Image:Cdo_export_targetdef0.png]]
+
Download the 4.1 baseline from [https://sourceforge.net/projects/net4j/files/Baselines https://sourceforge.net/projects/net4j/files/Baselines] and extract it to your local disk.
  
* Download the 4.0 baseline from [https://sourceforge.net/projects/net4j/files/Baselines/ SourceForge] and extract it into the _baseline project.
+
Add the API baseline to Eclipse. Open the <i>Preferences</i> (Window->Preferences) and go to the "API Baselines" page:
  
* Now add the API baseline: Open the <i>Preferences</i> (Window->Preferences) and open the "API Baselines" page.
+
[[Image:APIBaseline-4.1.png]]
  
[[Image:Cdo_export_targetdef3.png]]
+
Click "Add Baseline...". Give it the name ''CDO 4.1 Baseline'' and choose the path to the folder on your local disk where you've extracted the downloaded baseline to:
  
* Click "Add Baseline...". Give it the name ''CDO 4.0 Baseline'' and choose the path to your ''_baseline'' project as destination. Then the API baseline is created and set active for your workspace.
+
[[Image:APIBaseline-4.1-Add.png]]
  
[[Image:Cdo_export_targetdef4.png]]
+
Now the API baseline is created and set active for your workspace:
  
== Bootstrap the Releng Project  ==
+
[[Image:APIBaseline-4.1-Finish.png]]
  
Now you need to checkout the releng project (Buckminster releng component). Download an appropriate Subversive Team Project Set file:
+
== Materialize the Sources and the Target Platform  ==
  
{| cellspacing="1" cellpadding="2" border="1" width="200"
+
The materialization of the workspace contents (sources and binaries) will be performed by Buckminster with the cooperation of EGit and p2.  
|-
+
| <br>
+
| Users<br>
+
| Committers<br>
+
|-
+
| 4.1<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/trunk/plugins/org.eclipse.emf.cdo.releng/psf/bootstrap.psf Download]<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/trunk/plugins/org.eclipse.emf.cdo.releng/psf/bootstrap-committers.psf Download]<br>
+
|-
+
| 4.0<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/4.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap.psf Download]<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/4.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap-committers.psf Download]<br>
+
|-
+
| 3.0<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/3.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap.psf Download]<br>
+
| [http://dev.eclipse.org/svnroot/modeling/org.eclipse.emf.cdo/branches/3.0-maintenance/releng/org.eclipse.emf.cdo.releng/psf/bootstrap-committers.psf Download]<br>
+
|}
+
  
Select File->Import... and choose the Team Project Set import wizard. Select the downloaded bootstrap.psf
+
'''Hint:''' The p2 materializer might require lots of memory, and you might experience OutOfMemory Java errors while loading and resolving the target platform. You then might want to make sure your eclipse is configured properly, for instance using (in ''eclipse.ini''):
 +
<pre>--launcher.XXMaxPermSize
 +
256M
 +
-vmargs
 +
-Xms512m
 +
-Xmx1024m
 +
-XX:PermSize=256M
  
'''Hint:''' Instead of downloading the PSF-file, in Indigo you can copy the URL from the table above and import the Team Project Set directly from the copied URL.
+
</pre>
 +
'''For EGit to work properly please create the folder ${user.home}/git on your hard disk.''' (Alternatively you can start your eclipse instance with the following parameter: -Dgit.clone=D:/Development/git/cdo. Also set the default directory und Window-&gt;Preferences--&gt;Team--&gt;Git to "D:/Development/git)
  
[[Image:Cdo install10.png]]
+
Then start the Buckminster import wizard:  
  
[[Image:Cdo install11.png]]  
+
[[Image:Cdo import1.png]]  
  
[[Image:Cdo install12.png]]  
+
Point it to the Buckminster MSpec of CDO: [http://git.eclipse.org/c/cdo/cdo.git/plain/plugins/org.eclipse.emf.cdo.releng/local.mspec http://git.eclipse.org/c/cdo/cdo.git/plain/plugins/org.eclipse.emf.cdo.releng/local.mspec].
  
<br>
+
For a 4.1 maintenance workspace use [http://git.eclipse.org/c/cdo/cdo.git/plain/plugins/org.eclipse.emf.cdo.releng/local.mspec?h=streams/4.1-maintenance http://git.eclipse.org/c/cdo/cdo.git/plain/releng/org.eclipse.emf.cdo.releng/local.mspec?h=streams/4.0-maintenance] instead. Please note: This does not work until Buckminster [https://bugs.eclipse.org/bugs/show_bug.cgi?id=368573 bug 368573] is resolved (please '''vote''' for the bug!). Instead clone the entire Git repository manually, checkout the maintenance branch, search the workspace for 'local.mspec' and import it by right-clicking and selecting Buckminster-&gt;Import...
  
== Materialize the Sources and the Target Platform ==
+
[[Image:Cdo import2.png]]
  
To materialize the sources right-click the local.mspec, select Buckminster|Import...
+
Press the Load button and wait until Buckminster has resolved all the dependencies (go and fetch a coffee, or two, or three).  
  
[[Image:Cdo_install15.png]]
+
[[Image:Cdo import3.png]]  
  
While the following dialog is running go and fetch a coffee, or two, or three...
+
When the dependencies have been resolved properly hit the 'Finish' button:
  
 +
[[Image:Cdo import4.png]]
  
[[Image:Cdo_install16.png]]
+
Finally open the ''Preferences'' (Window-&gt;Preferences) and go to the "Target Platform" page. Edit the active target platform and remove the '''location''' (not the target platform definition as a whole!) that points to the running installation. Now you're done.
  
Finally hit the 'Finish' button
+
== Update the Workspace ==
  
[[Image:Cdo_install14.png]]
+
You can update your development workspace by re-importing the local.mpec (right-click + Buckminster + Import...). Then the whole workspace and the target platform are updated.
  
== Updating the Workspace ==
+
Note, that re-importing does only '''add''' new source projects but doesn't update existing source projects from the Git repository. Use the 'Pull' command of EGit for this purpose!
 
+
You can update your development workspace with re-importing the local.mpec as described above. Then the whole workspace and the target platform are updated.
+
 
+
Note, that re-importing doesn't update your source from the SVN repository. Use Subversive for this purpose!
+
 
+
== Tooling (Developers only) ==
+
 
+
Please do not forget to install install our versioning tool from [http://download.eclipse.org/modeling/emf/cdo/updates/integration http://download.eclipse.org/modeling/emf/cdo/updates/integration].
+
 
+
[[Image:CDO_Versioning_Tool.png]]
+

Revision as of 14:08, 6 April 2013

This tutorial describes how to install a CDO workspace using Buckminster.
The sources can also be browsed through http://git.eclipse.org/c/cdo/cdo.git/tree.
Binaries can be installed or downloaded from http://www.eclipse.org/cdo/downloads.

Contents

Prepare the IDE

Download and install Eclipse 3.8 from http://download.eclipse.org/eclipse/downloads/eclipse3x.php

Then open a fresh development workspace.

Cdo source1.png


Select the Juno (for 3.8) p2 repository and install the following features:

  • EMF - Eclipse Modeling Framework SDK
  • Graphical Modeling Framework (GMF) Notation SDK (needed for CDO Dawn)
  • Graphical Modeling Framework (GMF) Runtime SDK (needed for CDO Dawn)
  • Eclipse EGit

Select the Buckminster p2 repository and install the following features:

  • Buckminster - Core
  • Buckminster - Git Support
  • Buckminster - PDE Support

Select the Eclipse Project Updates p2 repository and install the following feature:

  • J2SE-1.5 Execution Environment Description

Committers: Please do not forget to install our versioning tool from http://download.eclipse.org/modeling/emf/cdo/updates/integration:

CDO Versioning Tool.png

Now you have prepared your IDE with the required tools.

Create the API Baseline

Non-committers may skip this section, but should instead reduce the problem marker severity for "Missing API baseline" from Error to Warning or Ignore (see screenshot below)!

APIBaseline-4.1-Ignore.png

Download the 4.1 baseline from https://sourceforge.net/projects/net4j/files/Baselines and extract it to your local disk.

Add the API baseline to Eclipse. Open the Preferences (Window->Preferences) and go to the "API Baselines" page:

APIBaseline-4.1.png

Click "Add Baseline...". Give it the name CDO 4.1 Baseline and choose the path to the folder on your local disk where you've extracted the downloaded baseline to:

APIBaseline-4.1-Add.png

Now the API baseline is created and set active for your workspace:

APIBaseline-4.1-Finish.png

Materialize the Sources and the Target Platform

The materialization of the workspace contents (sources and binaries) will be performed by Buckminster with the cooperation of EGit and p2.

Hint: The p2 materializer might require lots of memory, and you might experience OutOfMemory Java errors while loading and resolving the target platform. You then might want to make sure your eclipse is configured properly, for instance using (in eclipse.ini):

--launcher.XXMaxPermSize
256M
-vmargs
-Xms512m
-Xmx1024m
-XX:PermSize=256M

For EGit to work properly please create the folder ${user.home}/git on your hard disk. (Alternatively you can start your eclipse instance with the following parameter: -Dgit.clone=D:/Development/git/cdo. Also set the default directory und Window->Preferences-->Team-->Git to "D:/Development/git)

Then start the Buckminster import wizard:

Cdo import1.png

Point it to the Buckminster MSpec of CDO: http://git.eclipse.org/c/cdo/cdo.git/plain/plugins/org.eclipse.emf.cdo.releng/local.mspec.

For a 4.1 maintenance workspace use http://git.eclipse.org/c/cdo/cdo.git/plain/releng/org.eclipse.emf.cdo.releng/local.mspec?h=streams/4.0-maintenance instead. Please note: This does not work until Buckminster bug 368573 is resolved (please vote for the bug!). Instead clone the entire Git repository manually, checkout the maintenance branch, search the workspace for 'local.mspec' and import it by right-clicking and selecting Buckminster->Import...

Cdo import2.png

Press the Load button and wait until Buckminster has resolved all the dependencies (go and fetch a coffee, or two, or three).

Cdo import3.png

When the dependencies have been resolved properly hit the 'Finish' button:

Cdo import4.png

Finally open the Preferences (Window->Preferences) and go to the "Target Platform" page. Edit the active target platform and remove the location (not the target platform definition as a whole!) that points to the running installation. Now you're done.

Update the Workspace

You can update your development workspace by re-importing the local.mpec (right-click + Buckminster + Import...). Then the whole workspace and the target platform are updated.

Note, that re-importing does only add new source projects but doesn't update existing source projects from the Git repository. Use the 'Pull' command of EGit for this purpose!