Skip to main content
Jump to: navigation, search

Difference between revisions of "Building the Higgins I-Card Manager Service"

(Build Instructions)
m (recategorized)
 
(41 intermediate revisions by 8 users not shown)
Line 1: Line 1:
== General CVS Information ==
+
{{#eclipseproject:technology.higgins|eclipse_custom_style.css}}
{| class="wikitable" style="text-align:left; border="1" cellpadding="5" cellspacing="0" 
+
This page contains instructions on how to check out and build web application from the source code of the involved Higgins components. See [[Firefox-Embedded Selector Solution]] for more information on the involved Higgins components and how they interact with each other, and see [[Deploying the Higgins I-Card Manager Service]] for information on how to deploy and configure this web application.
| rowspan="2" | Connection Type
+
| Committers
+
| :ext:
+
|-
+
| Anonymous access
+
| :pserver:
+
|-
+
| colspan="2" | Host
+
| dev.eclipse.org
+
|-
+
| colspan="2" | Repository Path
+
| /cvsroot/technology
+
|-
+
|} 
+
  
 +
==Prerequisites==
  
== I-Card Manager Projects ==
+
This guide assumes you have the following software:
Main I-Card Manager project is
+
* Eclipse IDE 3.3 or later (see http://www.eclipse.org/)
 +
* Subclipse svn plug- in v 1.2.4 or later (see http://subclipse.tigris.org/)
 +
* Web standard tools 2.0.1 or later (see http://www.eclipse.org/webtools/)
 +
* Apache Tomcat 5.5 or later (or other servlet container)
 +
* JDK 1.4 or later
 +
 
 +
==Set up your Eclipse workspace==
 +
 
 +
===Open a blank workspace===
 +
 
 +
After you start Eclipse, it should display a blank workspace. If you have already been working in Eclipse and your workspace is not empty, you can create a new empty one by selecting File -> Switch Workspace -> Other. Select a folder to use for your new, blank workspace. Your workspace should look like this:
 +
 
 +
[[Image:saml2idp-setup1.png|thumb|none|Blank Eclipse workspace]]
 +
 
 +
Make sure your blank workspace is configured to build all projects automatically:
 +
 
 +
[[Image:Blank-Build-Automatically.PNG|thumb|none|Build Automatically]]
 +
 
 +
===Configure JDK===
 +
 
 +
You should configure your Eclipse IDE to use JDK instead of JRE in order to be able to use Java compiler from ant scripts to build the Higgins components. Click Window -> Preferences and select Java -> Installed JREs. The default JRE is the one that was used to launch Eclipse, however you need to add a different one and set it as the workspace-default one for building. Higgins components are usually built with a Java 1.4 compiler.
 +
 
 +
[[Image:saml2idp-setup11.png|thumb|none|Configure JRE]]
 +
 
 +
''Note: You should also check Java -> Compiler -> Compiler compliance level, and make sure this matches the JRE you use to build the projects.''
 +
 
 +
===Configure server runtime===
 +
 
 +
In order to work with web applications, Eclipse needs to know about the servlet container (e.g. Tomcat) you want to use. Click Window -> Preferences and select Server -> Installed Runtimes. Click "Add...". Select the server you want to use (e.g. Tomcat 5.5), click "Next", specify the installation directory and click "Finish".
 +
 
 +
[[Image:saml2idp-setup10.png|thumb|none|Configure server runtime]]
 +
 
 +
''Note: It is recommended to install Tomcat at a path that does not contain any spaces.''
 +
 
 +
==Populate the Eclipse workspace==
 +
 
 +
The next step is to populate your Eclipse workspace with the required projects. This could be done in two simple steps:
 +
 
 +
* Check out main project.
 +
* Check out required projects.
 +
 
 +
===Check out main project===
 +
 
 +
First of all import '''org.eclipse.higgins.icm''' project into workspace, click '''File -> Import'''. In the import source list, select '''Other -> Checkout Projects from SVN'''. The URL for connecting to the Eclipse SVN is as follows:
  
 
{| class="wikitable" style="text-align:left; border="1" cellpadding="5" cellspacing="0"   
 
{| class="wikitable" style="text-align:left; border="1" cellpadding="5" cellspacing="0"   
|-style="background:#d6dee9; color:black" 
 
! border="1" align="left" valign="top" | Project
 
! border="1" align="left" valign="top" | Module Location
 
! border="1" align="left" valign="top" | Eclipse PSF
 
! border="1" align="left" valign="top" | ViewCVS
 
 
|-
 
|-
|rowspan="2" |I-Card Manager
+
| https://dev.eclipse.org/svnroot/technology
|rowspan="2" |org.eclipse.higgins/app/org.eclipse.higgins.icm
+
| [http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.higgins/app/org.eclipse.higgins.icm/anonymous.psf?root=Technology_Project&view=co anonymous]
+
|rowspan="2" | [http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.higgins/app/org.eclipse.higgins.icm/?root=Technology_Project viewcvs]
+
|-
+
| [http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.higgins/app/org.eclipse.higgins.icm/committer.psf?root=Technology_Project&view=co committer]
+
 
|-
 
|-
 
|}
 
|}
  
== Build Instructions ==
+
Checkout '''org.eclipse.higgins.icm''' project from '''https://dev.eclipse.org/svnroot/technology/org.eclipse.higgins/trunk/app/org.eclipse.higgins.icm'''
* '''Building within Eclipse IDE:'''
+
** The normal project build method will compile the source
+
** How to export a WAR file from a Web project:
+
*** Right click on a Web project folder and select Export from the pop-up menu. Then select WAR file in the Export window and then select Next.
+
*** Specify the Web project you want to export (this field is primed if you used the pop-up menu to open the wizard), and specify a location for the new WAR file.
+
*** Optional: Optionally, supply WAR export Options, such as whether or not to include Java™ source files in the WAR, and whether to overwrite any existing resources during the export process. Source files are not usually included in a WAR file, because they are not necessary for the server to run the web application.
+
*** Click Finish.
+
  
* '''Command-line builds:'''
+
''Note: This may take several minutes, depending on your internet connection and current Eclipse server load.''
** How to create a client stub Jar lib:
+
*** From the project directory, run '''wsbuild.xml''' ant script. Resulting '''wsstub.jar''' lib will be placed inside the WEB-INF/lib directory.
+
  
* '''Builds notes:'''  
+
===Check out required projects===
** The Eclipse Web Tools Platform should be installed. [http://www.eclipse.org/webtools/main.php More about WTP].
+
 
** Assume that you have installed the JWSDP from [http://java.sun.com/webservices/ http://java.sun.com/webservices] and defined the Windows environment variable %JWSDP_HOME%
+
# Right click on org.eclipse.higgins.icm/'''projectWithDeps.psf -> Import Project Set ...'''
 +
# Answer '''No''' on the request whether to override '''org.eclipse.higgins.icm''' project
 +
 
 +
''Note: This may take several minutes, depending on your internet connection and current Eclipse server load.''
 +
 
 +
After checking out the projects, your workspace should be without build errors.
 +
 
 +
==Build Web Application==
 +
 
 +
Unfold ''org.eclipse.higgins.icm''-project contents in Package Explorer, choose '''build.xml''' and push the right mouse button (if this file already opened, push the right mouse button on the edit area). In popup menu choose item '''Run AS->Ant Build'''.
 +
 
 +
[[Image:ICM BUILD.JPG|thumb|none|Choose popup menu item]]
 +
 
 +
For correct complete build procedure you must have installed Java JDK, not JRE. (Also be sure, what enviroment variable JAVA_HOME contain path to JDK)
 +
 
 +
In the opened window ''"Edit configuration and launch"'', in tab '''Targets''' choose targets name ''''war''''.
 +
 
 +
[[Image:ICM TARGETS.JPG|thumb|none|Choose targets name]]
 +
 
 +
Pass to tab ''JRE''. In the field "Separate JRE" you must choose from dropdown list needed JDK. If JDK is missed in list, you must install it.
 +
 
 +
[[Image:Jre-jdk.JPG|thumb|none|Edit configuration and launch]]
 +
 
 +
If you want to build org.eclipse.higgins.icm without Eclipse you can do that from console. Start console in a project folder. Then execute ''"ant war"''. For executing this command you must have preinstalled Ant on you system.
 +
 
 +
When build is proceed, all related projects also will be builded.
 +
 
 +
As result, the folder '''*\org.eclipse.higgins.icm\build\war''' will contain '''icm.war'''.
  
 
== See Also ==
 
== See Also ==
* [http://www.eclipse.org/higgins Higgins Home]
+
 
* [[Components]]
+
To configure and deploy this web application see: [[Deploying the Higgins I-Card Manager Service]]
 +
 
 +
[[Category:Higgins 1.x - Building]]

Latest revision as of 16:49, 25 April 2011

{{#eclipseproject:technology.higgins|eclipse_custom_style.css}} This page contains instructions on how to check out and build web application from the source code of the involved Higgins components. See Firefox-Embedded Selector Solution for more information on the involved Higgins components and how they interact with each other, and see Deploying the Higgins I-Card Manager Service for information on how to deploy and configure this web application.

Prerequisites

This guide assumes you have the following software:

Set up your Eclipse workspace

Open a blank workspace

After you start Eclipse, it should display a blank workspace. If you have already been working in Eclipse and your workspace is not empty, you can create a new empty one by selecting File -> Switch Workspace -> Other. Select a folder to use for your new, blank workspace. Your workspace should look like this:

Blank Eclipse workspace

Make sure your blank workspace is configured to build all projects automatically:

Build Automatically

Configure JDK

You should configure your Eclipse IDE to use JDK instead of JRE in order to be able to use Java compiler from ant scripts to build the Higgins components. Click Window -> Preferences and select Java -> Installed JREs. The default JRE is the one that was used to launch Eclipse, however you need to add a different one and set it as the workspace-default one for building. Higgins components are usually built with a Java 1.4 compiler.

Configure JRE

Note: You should also check Java -> Compiler -> Compiler compliance level, and make sure this matches the JRE you use to build the projects.

Configure server runtime

In order to work with web applications, Eclipse needs to know about the servlet container (e.g. Tomcat) you want to use. Click Window -> Preferences and select Server -> Installed Runtimes. Click "Add...". Select the server you want to use (e.g. Tomcat 5.5), click "Next", specify the installation directory and click "Finish".

Configure server runtime

Note: It is recommended to install Tomcat at a path that does not contain any spaces.

Populate the Eclipse workspace

The next step is to populate your Eclipse workspace with the required projects. This could be done in two simple steps:

  • Check out main project.
  • Check out required projects.

Check out main project

First of all import org.eclipse.higgins.icm project into workspace, click File -> Import. In the import source list, select Other -> Checkout Projects from SVN. The URL for connecting to the Eclipse SVN is as follows:

https://dev.eclipse.org/svnroot/technology

Checkout org.eclipse.higgins.icm project from https://dev.eclipse.org/svnroot/technology/org.eclipse.higgins/trunk/app/org.eclipse.higgins.icm

Note: This may take several minutes, depending on your internet connection and current Eclipse server load.

Check out required projects

  1. Right click on org.eclipse.higgins.icm/projectWithDeps.psf -> Import Project Set ...
  2. Answer No on the request whether to override org.eclipse.higgins.icm project

Note: This may take several minutes, depending on your internet connection and current Eclipse server load.

After checking out the projects, your workspace should be without build errors.

Build Web Application

Unfold org.eclipse.higgins.icm-project contents in Package Explorer, choose build.xml and push the right mouse button (if this file already opened, push the right mouse button on the edit area). In popup menu choose item Run AS->Ant Build.

Choose popup menu item

For correct complete build procedure you must have installed Java JDK, not JRE. (Also be sure, what enviroment variable JAVA_HOME contain path to JDK)

In the opened window "Edit configuration and launch", in tab Targets choose targets name 'war'.

Choose targets name

Pass to tab JRE. In the field "Separate JRE" you must choose from dropdown list needed JDK. If JDK is missed in list, you must install it.

Edit configuration and launch

If you want to build org.eclipse.higgins.icm without Eclipse you can do that from console. Start console in a project folder. Then execute "ant war". For executing this command you must have preinstalled Ant on you system.

When build is proceed, all related projects also will be builded.

As result, the folder *\org.eclipse.higgins.icm\build\war will contain icm.war.

See Also

To configure and deploy this web application see: Deploying the Higgins I-Card Manager Service

Back to the top