Jump to: navigation, search

Difference between revisions of "Buckminster Optional Features"

(org.eclipse.buckminster.subclipse.feature)
 
(One intermediate revision by the same user not shown)
Line 13: Line 13:
 
Contains the CSPEC generation and eclipse.import reader. If you work with plug-ins and features you are likely to need this feature. It depends on the PDE functionality provided by the Eclipse IDE and it will only work if you have this installed. PDE is included in the ''Eclipse for RCP/Plug-in Developers'' or ''Eclipse Classic packages''.
 
Contains the CSPEC generation and eclipse.import reader. If you work with plug-ins and features you are likely to need this feature. It depends on the PDE functionality provided by the Eclipse IDE and it will only work if you have this installed. PDE is included in the ''Eclipse for RCP/Plug-in Developers'' or ''Eclipse Classic packages''.
 
=org.eclipse.buckminster.subclipse.feature=
 
=org.eclipse.buckminster.subclipse.feature=
Provides support for Subversion using the popular [http://subclipse.tigris.org Subclipse] plug-in. This feature requires that you also install that plug-in.
+
Provides support for Subversion using the popular [http://subclipse.tigris.org Subclipse] plug-in. You don't need to install the subclipse team provider separately as this feature contains everything you need. Please note that this feature is mutually exclusive with the org.eclipse.buckminster.subversive.feature. You must '''never''' install both of them.
Please note that this feature is mutually exclusive with the org.eclipse.buckminster.subversive.feature. You must '''never''' install both of them.
+
 
 
=org.eclipse.buckminster.subversive.feature=
 
=org.eclipse.buckminster.subversive.feature=
Provides support for Subversion using the [http://www.eclipse.org/subversive org.eclipse.team.svn] plug-in. This feature requires that you also install that plug-in. Look [http://www.eclipse.org/subversive/documentation/gettingStarted/aboutSubversive/install.php here for install instructions].
+
Provides support for Subversion using the [http://www.eclipse.org/subversive org.eclipse.team.svn] plug-in. You don't need to install the subversive team provider separately as this feature contains everything you need.
 
Please note that this feature is mutually exclusive with the org.eclipse.buckminster.subclipse.feature. You must '''never''' install both of them.
 
Please note that this feature is mutually exclusive with the org.eclipse.buckminster.subclipse.feature. You must '''never''' install both of them.
 +
 
=org.eclipse.buckminster.remote.feature=
 
=org.eclipse.buckminster.remote.feature=
 
This feature contains the RCP-based remote service implementation. In order to use it, you must also install a plug-in from a provider that enables such a service.
 
This feature contains the RCP-based remote service implementation. In order to use it, you must also install a plug-in from a provider that enables such a service.

Latest revision as of 12:21, 11 September 2008

Buckminster is distributed as a set of fairly fine-grained features. Each feature provides some specific support and it is up to you to configure your installation for your own needs.

The update manager, with its tree structure, might encourage you to install all features by simply checking the top check-box. When installing Buckminster this is a really bad idea since some features are mutually exclusive and others are likely to bring you no benefit at all.

This is an overview of the optional features. All features will require the installation of the org.eclipse.buckminster.core.feature and some features will add additional requirements.

org.eclipse.buckminster.cvs.feature

This feature provides CVS support on top of the org.eclipse.team.cvs plugin that is provided with the Eclipse platform.

org.eclipse.buckminster.maven.feature

This feature will enable resolution and materialization from Maven repositories (Maven and Maven2 are both supported).

org.eclipse.buckminster.p4.feature

Using this feature, you will be able to resolve and materialize from Perforce (p4) SCM repositories. It doesn't have any additional dependencies but it will discover and cooperate with the P4WSAD plugin if it finds it.

org.eclipse.buckminster.pde.feature

Contains the CSPEC generation and eclipse.import reader. If you work with plug-ins and features you are likely to need this feature. It depends on the PDE functionality provided by the Eclipse IDE and it will only work if you have this installed. PDE is included in the Eclipse for RCP/Plug-in Developers or Eclipse Classic packages.

org.eclipse.buckminster.subclipse.feature

Provides support for Subversion using the popular Subclipse plug-in. You don't need to install the subclipse team provider separately as this feature contains everything you need. Please note that this feature is mutually exclusive with the org.eclipse.buckminster.subversive.feature. You must never install both of them.

org.eclipse.buckminster.subversive.feature

Provides support for Subversion using the org.eclipse.team.svn plug-in. You don't need to install the subversive team provider separately as this feature contains everything you need. Please note that this feature is mutually exclusive with the org.eclipse.buckminster.subclipse.feature. You must never install both of them.

org.eclipse.buckminster.remote.feature

This feature contains the RCP-based remote service implementation. In order to use it, you must also install a plug-in from a provider that enables such a service.