Jump to: navigation, search

BIRT Migration Guide

Revision as of 00:59, 10 August 2011 by Jweathersby.actuate.com (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

One of the goals of the BIRT project is to continue to move the project forward while remaining compatible with previous versions to the greatest extent possible. This page links to individual guides that cover any known migration issues when moving from an older version of BIRT to the latest version. Select the migration guide for the version of BIRT you plan on upgrading to for specific details on Viewer deployment, Engine(s) API changes, and architectural changes.

If you know of any migration issues not documented on this page, please add them.

BIRT 3.7: Moving from BIRT 2.6 to BIRT 3.7 or Later

In BIRT 3.7 the Viewer and Engine deployment have been updated based on community feedback to make it easier to deploy BIRT. This has resulted in some changes to the Engine API, Viewer structure and file locations. If you are moving to BIRT 3.7 or later from an earlier release you will need to make some changes. These changes are documented in the BIRT 3.7 Migration Guide.