Jump to: navigation, search

Difference between revisions of "Aperi/build/dev-env"

(org.mortbay.jaas 5.1.10)
(Apache Xerces 2.8.1: Removed)
Line 128: Line 128:
 
* Rename ''hbaapitest.c'' to ''hbalib.c'' in A''peri\device\SNIA\commonAPI''
 
* Rename ''hbaapitest.c'' to ''hbalib.c'' in A''peri\device\SNIA\commonAPI''
  
==== Apache Xerces 2.8.1 ====
+
 
* Go to http://archive.apache.org/dist/xml/xerces-j/.
+
* Click on ''Xerces-J-bin.2.8.1.zip'' and download the file.
+
* Extract the zip file to ''C:\Aperi-Dev\Etc''
+
* Import into project ''org.apache.xerces'' both ''xercesImpl.jar'' and ''xml-apis.jar'' from ''C:\Aperi-Dev\Etc\Xerces-J-Tools.2.8.1\tools''.
+
  
 
==== SBLIM CIM Client 1.3 ====
 
==== SBLIM CIM Client 1.3 ====

Revision as of 10:53, 4 May 2007

Aperi Development Environment

This document describes how to set up a development environment on a “clean” Windows machine for working with Aperi. This includes:

  • Setting up a development environment
  • Downloading the Aperi source code
  • Downloading third-party libraries
  • Building aperi
  • Running Aperi in a debug environment

1. Begin setting up the development environment

Perform this step to begin establishing the appropriate development environment on a Windows machine. The following components are needed for the environment:

Create a directory - C:\Aperi-Dev\BuildTools\ to house the tools needed to build Aperi.

Create a directory - C:\Aperi-Dev\Etc to house downloaded packages integrated into the product

Java 1.5 JDK

  • Go to http://java.sun.com/javase/downloads/index.jsp
  • Click Download next to JDK 5.0 Update 9 with Java EE.
  • Click Accept License Agreement.
  • Click Java EE SDK 5 Update 1 for Windows to download the jdk-1_5_0_09-windows-i586-p.exe file.
  • Run the executable and accept the default settings.

MSVC 6.0 (MS Visual C) + SP6

Use this component to compile the native code to the Windows platform. Install this into the default directory. Aperi assumes this default location to be: "C:\Program Files\Microsoft Visual Studio\VC98\" If you have a licensed copy of MSVC 6.0 you can download service pack 6 from here: http://www.microsoft.com/downloads/details.aspx?familyid=A8494EDB-2E89-4676-A16A-5C5477CB9713&displaylang=en

NTDDK

The version of the DDK available at that site is Windows Server 2003 SP1. It supports versions of Windows going back to Windows 2000. An ISO download is available. To avoid burning it to a CD prior to installation, you can use WinRAR (http://www.rarlab.com/ ) to extract the contents of the ISO to a local folder. When installing, stick with all of the defaults. There's no need to install any of the samples. By default, the files are written to the following directory: C:\WINDDK\3790.1830.

DXSDK

The version of the Platform SDK available at that site is Windows Server 2003 SP1. Similar to the DDK, it supports versions of Windows going back to Windows 2000. Download the appropriate file for your system (ex: PSDK-x86.exe). Double click this file on the target system and install everything. The install is web-based, and will thus take some time. By default, the Platform SDK files are written to the following directory: C:\Program Files\Microsoft Platform SDK.


Eclipse SDK 3.2.1

  • Go to http://www.eclipse.org/downloads/.
  • Click Eclipse SDK 3.2.1.
  • Click a mirror link and download the eclipse-SDK-3.2.1-win32.zip file.
  • Extract the contents of the zip file to C:\Aperi-Dev\BuildTools\eclipse-SDK-3.2.1-win32.

Ant 1.7.0

  • Go to http://ant.apache.org/bindownload.cgi.
  • Click apache-ant-1.7.0-bin.zip in the Current Release of Ant section to download Ant 1.7.0.
  • Unzip the distribution file into C:\Aperi-Dev\BuildTools\. The resulting ANT_HOME directory should be C:\Aperi-Dev\BuildTools\apache-ant-1.7.0.

JSch 0.1.31

  • Download jsch-0.1.31.jar to C:\Aperi-Dev\BuildTools\apache-ant-1.7.0\lib\jsch-0.1.31.jar.

2. Downloading Aperi Source and Eclipse Components

Perform these steps to download Aperi source into your Eclipse IDE.

  • Start the Eclipse IDE by running: C:\dev\eclipse-SDK-3.2.1-win32\eclipse\eclipse.exe.
  • Select a workspace directory of C:\Aperi-Dev\Code.
  • Import the aperi.psf file. Importing this file will automatically download the Aperi source code in addition to other leveraged Eclipse components.

To import this file, complete the following steps:

  • Select File > Import.
  • Select Team > Team Project Set.
  • Browse and select aperi.psf. You can download this file from CVS.

3. Downloading Third Party Packages

Perform these steps to download important third-party libraries and complete the Aperi runtime code base.

Turn off Eclipse automatic builds until all steps are complete.

Library Required Files Location of Library
SNIA HBA API 2.2 hbaapi_src_2.2.tgz http://prdownloads.sourceforge.net/hbaapi/
Apache Xerces 2.8.1 Xerces-J-tools.2.8.1.zip http://archive.apache.org/dist/xml/xerces-j/
SBLIM CIM Client 1.3.1 sblim-cim-client-1.3.1-bin.zip http://sourceforge.net/project/showfiles.php?group_id=128809
JavaHelp 1.1.3 jh.jar http://java.sun.com/products/javahelp/download_binary.html
Geronimo 1.1 geronimo-j2ee_1.4_spec-1.1.jar http://www.apache.org/dist/geronimo/1.1/geronimo-tomcat-j2ee-1.1.zip
BIRT Runtime 2.1.2 birt-runtime-2.1.2.zip http://www.eclipse.org/downloads/download.php?file=/birt/downloads/drops/R-R1-2_1_2-200702271000/birt-runtime-2.1.2.zip
org.mortbay.jaas 5.1.10 org.mortbay.jaas-5.1.10.jar http://repo1.maven.org/maven2/jetty/org.mortbay.jaas/5.1.10/org.mortbay.jaas-5.1.10.jar
Dojo Toolkit 0.4.2 dojo-0.4.2-ajax.tar.gz http://download.dojotoolkit.org/release-0.4.2/dojo-0.4.2-ajax.tar.gz
iText 1.3 itext-1.3.jar http://downloads.sourceforge.net/itext/itext-1.3.jar?modtime=1112806930&big_mirror=0


SNIA HBA API 2.2

Note: You must be able to decompress .tgz files to complete the download of this library.

  • Go to http://prdownloads.sourceforge.net/hbaapi/.
  • Under 'File Releases' click the link for 'hbaapi_src_2.2.tgz' under the 'hbaapi-src' heading
  • Decompress hbaapi_src_2.2.tgz to C:\Aperi-Dev\Etc\hbaapi_src_2.2
  • Import hbaapi.h and vendorhbaapi.h into project directory Aperi\data\c\T-Storm
  • Import hbaapi.h, HBAAPILIB.c, hbaapitest.c, and vendorhbaapi.h into Aperi\device\SNIA\commonAPI.
  • Rename hbaapitest.c to hbalib.c in Aperi\device\SNIA\commonAPI


SBLIM CIM Client 1.3

  • Go to http://sourceforge.net/project/showfiles.php?group_id=128809.
  • Under 'File Releses' expand the '1.3.1' node under sblim-cim-client.
  • Click on and Download sblim-cim-client-1.3.1-bin.zip.
  • Extract the zip file to C:\Aperi-Dev\Etc
  • Import into project org.sblim.cim.client the file C:\Aperi-Dev\Etc\sblim-cim-client-1.3.1\cim-client\sblimCIMClient.jar
  • Import into project org.sblim.slp the file C:\Aperi-Dev\Etc\sblim-cim-client-1.3.1\cim-client\sblimSLPClient.jar

JavaHelp 1.1.3

  • Go to http://java.sun.com/products/javahelp/download_binary.html.
  • Click the Download button under the JavaHelp 1.1.3 (Zip) section.
  • Click Accept License Agreement.
  • Click the down arrow to download the javahelp-1_1_3.zip file.
  • Unzip the contents of the downloaded file to C:\Aperi-Dev\Etc
  • Import into javax.help the file C:\Aperi-Dev\Etc\jh1.1.3\javahelp\lib\jh.jar

Geronimo 1.1

BIRT Runtime 2.1.2

  • Download the BIRT runtime.
  • Unzip the file to C:\Aperi-Dev\Etc
  • Import to org.eclipse.aperi.reporting\web\birt-viewer the contents of C:\Aperi-Dev\Etc\birt-runtime-2_1_2\WebViewerExample except for the file birt-viewer\WEB-INF\web.xml, your import dialog should look like this:

Aperi-importReporting.PNG

org.mortbay.jaas 5.1.10

  • Download the org.mortbay.jaas jar.
  • Copy the jar to C:\Aperi-Dev\Etc
  • Rename the jar from org.mortbay.jaas-5.1.10.jar to org.mortbay.jaas.jar
  • Import C:\Aperi-Dev\Etc\org.mortbay.jaas.jar into org.eclipse.aperi.reporting.jaas

Dojo Toolkit 0.4.2

  • Download the Dojo toolkit
  • Extract the downloaded tarball to C:\Aperi-Dev\Etc
  • Import into org.eclipse.aperi.reporting\web\aperi-reports\dojoAjax the contents of C:\Aperi-Dev\Etc\dojo-0.4.2-ajax

iText 1.3

  • Download the iText jar
  • Copy the jar to C:\Aperi-Dev\Etc
  • Import C:\Aperi-Dev\Etc\itext-1.3.jar into the org.eclipse.aperi.reporting/web/birt-viewer/WEB-INF/lib directory.

4a. Building Aperi on Windows

  • Make sure the C:\Aperi-Dev\Code\Aperi\build_env.bat file is updated so that variables are correct. A default directory, C:\Aperi-Dev\BuildTools\, is used to house the tools needed to build Aperi. If this directory not used, build_env.bat should be updated accordingly.
  • Launch ResetDebugEnvironment from Eclipse. This launch script is preconfigured to build the native code on a Windows platform. The image below illustrates the launch.

Aperi-build-1.PNG

NOTE: If the launch scripts do not appear as illustrated in the above image, there is a small work around. Go to Window -> Open Perspective -> Other -> CVS Repository Exploring. “Re-check out” the AperiDebug project. For some reason, this resolves the problem. You should now see the scripts as illustrated above. Launch ‘ResetDebugEnvironment’.

Aperi-build-2.PNG

  • Launch RunConfigureAperiIDE to install Aperi and creates a runtime Derby database.

Aperi-build-3.PNG

4b. Building Aperi on Linux

  • Create a Linux aperi build user:
    username: aperi
    password: aperi
    home directory: /home/aperi
  • Verify you have SSH access to localhost
    ssh aperi@localhost
  • Make a symbolic link from "/usr/lib/jvm/jdk1.5.0" to the Sun JDK.
  • Make sure the /Aperi-Dev/Code/Aperi/build_env.sh file is updated so that variables are correct. A default directory, /Aperi-Dev/BuildTools/, is used to house the tools needed to build Aperi. If this directory not used, build_env.sh should be updated accordingly.
  • If you would like to compile the native code then Launch CompileNativeLinux_FromLinux. If not, proceed to the next step.

Aperi-build-linux-1.PNG

  • Launch ResetDebugEnvironmentLinux from Eclipse. The image below illustrates the launch.

Aperi-build-linux-2.PNG

NOTE: If the launch scripts do not appear as illustrated in the above image, there is a small work around. Go to Window -> Open Perspective -> Other -> CVS Repository Exploring. “Re-check out” the AperiDebug project. For some reason, this resolves the problem. You should now see the scripts as illustrated above. Launch ‘ResetDebugEnvironment’.

Aperi-build-2.PNG

  • Launch RunConfigureAperiIDE to install Aperi and creates a runtime Derby database.

Aperi-build-3.PNG

5. Running Aperi in a debug environment

If the configuration completes successfully, Aperi is ready to start. Launch the following processes in the following order:

  • RunAperiDerbyDB
  • RunAperiDataServer
  • RunAperiDeviceServer
  • RunAperiAgent
  • RunAperiLegacyGUI
  • RunAperiReportServer