Ant/Java8

From Eclipsepedia

< Ant
Revision as of 14:25, 17 June 2013 by Michael rennie.ca.ibm.com (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Platform Ant
Website
Download
Community
Mailing ListForumsIRC
Bugzilla
Open
Help Wanted
Bug Day
Contribute
Browse SourceProject Set File

The version of Ant that ships with Eclipse Kepler (4.3) does not correctly handle Java 8™. This is because Java 8™ support was added to Apache Ant for version 1.9.1 and the version available in Eclipse Kepler is 1.8.4.

There are two workarounds:

  1. Wait for the 1.9.1 update to Eclipse - to be applied at the start of Luna (bug 395421)
  2. Point Eclipse at the new version of Ant. This help topic describes how to do so.