Jump to: navigation, search

Difference between revisions of "Acceleo/Views Perspective"

m (New page: = Views and Perspective = Acceleo contains several views in its perspective in order to help the user during the development of its generators. = Overrides View = = Result View = see [[...)
 
m (Perspective and view activation)
 
(3 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
= Views and Perspective =
 
= Views and Perspective =
Acceleo contains several views in its perspective in order to help the user during the development of its generators.
+
Acceleo contains several views in its perspective in order to help the user during the development of its generators. You can activate the Acceleo perspective with the menu Window -> Open Perspective -> Other... and then click on Acceleo. The views can be accessed from the perspective or in any perspective with the menu Window -> Show View -> Other... -> Acceleo Model to Text.
  
 
= Overrides View =
 
= Overrides View =
 +
The Overrides view allows the user to see all the Acceleo modules available in its workspace and in its plug-ins.
 +
[[Image:Acceleo-overrides-view.png|thumb|none|600px|The Overrides view showing the modules in the workspace and in the plug-ins]]
 +
 +
 +
With this view, you can quickly see those modules by double clicking on them by you can also select one of those module to override it.
 +
[[Image:Acceleo-overrides-completion.png|thumb|none|415px|The completion created by the selection in the Overrides view.]]
 +
 +
 +
After having selected a template, use the completion to override it in an existing module.
 +
[[Image:Acceleo-overrides-result.png|thumb|none|600px|The new template created thanks to the Overrides view.]]
 +
 +
 +
This view can help you find a module in your Eclipse platform, it can also be used to quickly and easily override several templates of a module.
  
  
 
= Result View =
 
= Result View =
see [[Acceleo/Traceability|Traceability]]
+
The Result view is used to display the traceability information computed during the generation. To learn more about this view and the traceability of Acceleo, you can go to the [[Acceleo/Traceability|Traceability article]].
 +
 
 +
[[Image:Acceleo-traceability-result.png|thumb|none|400px|The Result view with some traceability informations.]]
 +
 
  
 
= Generation Pattern =  
 
= Generation Pattern =  
In order to customize the completion process with custom template using the input metamodel.
+
The Generation Pattern view allows the user to select one of the common design pattern of code generation and to choose the elements on which the pattern will apply.
  
/!\ in construction /!\
+
[[Image:Acceleo-generationpattern-view.png|thumb|none|600px|The Generation Pattern view for an Acceleo module with the UML metamodel]]
 +
 
 +
 
 +
After this selection, the pattern can be used thanks to the completion mechanism of the Acceleo editor.
 +
 
 +
[[Image:Acceleo-generationpattern-completion.png|thumb|none|400px|The completion proposal from the Generation Pattern view.]]
 +
 
 +
 
 +
And here you can see the result of a design pattern used to create a new template for all kinds of UML "classifier".
 +
 
 +
[[Image:Acceleo-generationpattern-result.png|thumb|none|432px|The templates generated thanks to the Generation Pattern view.]]
  
  
 
{{Acceleo-index}}
 
{{Acceleo-index}}
 +
 +
[[Category:Modeling]]
 +
[[Category:M2T]]
 +
[[Category:Acceleo]]

Latest revision as of 14:48, 12 January 2011

Views and Perspective

Acceleo contains several views in its perspective in order to help the user during the development of its generators. You can activate the Acceleo perspective with the menu Window -> Open Perspective -> Other... and then click on Acceleo. The views can be accessed from the perspective or in any perspective with the menu Window -> Show View -> Other... -> Acceleo Model to Text.

Overrides View

The Overrides view allows the user to see all the Acceleo modules available in its workspace and in its plug-ins.

The Overrides view showing the modules in the workspace and in the plug-ins


With this view, you can quickly see those modules by double clicking on them by you can also select one of those module to override it.

The completion created by the selection in the Overrides view.


After having selected a template, use the completion to override it in an existing module.

The new template created thanks to the Overrides view.


This view can help you find a module in your Eclipse platform, it can also be used to quickly and easily override several templates of a module.


Result View

The Result view is used to display the traceability information computed during the generation. To learn more about this view and the traceability of Acceleo, you can go to the Traceability article.

The Result view with some traceability informations.


Generation Pattern

The Generation Pattern view allows the user to select one of the common design pattern of code generation and to choose the elements on which the pattern will apply.

The Generation Pattern view for an Acceleo module with the UML metamodel


After this selection, the pattern can be used thanks to the completion mechanism of the Acceleo editor.

The completion proposal from the Generation Pattern view.


And here you can see the result of a design pattern used to create a new template for all kinds of UML "classifier".

The templates generated thanks to the Generation Pattern view.



Acceleo Portal
Project Project · Installation · New & noteworthy · Release review · API policy · Retention policy · Next · Checklist
Features Acceleo Features · Runtime · Acceleo editor · Views & Perspective · Debugger · Profiler · Traceability · Wishlist · Interpreter · Maven
User documentation Getting Started · Acceleo operations reference · OCL operations reference · Text Production Rules · Migration From Acceleo 2.x · Best Practices · Videos · FAQ
Developer documentation Source code · How to contribute · Compatibility · MOFM2T specification · OCL specification
Community Conferences · Twitter & Blogs · Professional Support · Report a bug