Difference between revisions of "AMW FAQ"

From Eclipsepedia

Jump to: navigation, search
 
Line 17: Line 17:
  
 
==Which version of AMW, AM3 and ATL should be installed to avoid version problems?==
 
==Which version of AMW, AM3 and ATL should be installed to avoid version problems?==
The required versions of the three plugins are mentioned in the corresponding download pages: [http://www.eclipse.org/gmt/amw/download/ AMW], [http://www.eclipse.org/gmt/amw/download/ AM3], [http://www.eclipse.org/gmt/amw/download/ ATL]. <p/>
+
The required versions of the three plugins are mentioned in the corresponding download pages: [http://www.eclipse.org/gmt/amw/download/ AMW], [http://www.eclipse.org/gmt/am3/download/ AM3], [http://www.eclipse.org/gmt/atl/download/ ATL]. <p/>
  
 
==Why the menu "Extract ATL-0.2 model into ATL-0.2 file" does not appear when I try to extract an ATL model that was created from a weaving model?==
 
==Why the menu "Extract ATL-0.2 model into ATL-0.2 file" does not appear when I try to extract an ATL model that was created from a weaving model?==
 
Specific extraction and injection menus are available only in the "AM3 Resource Navigator", not in the  
 
Specific extraction and injection menus are available only in the "AM3 Resource Navigator", not in the  
 
"Package Explorer" view.
 
"Package Explorer" view.

Revision as of 09:47, 10 October 2006

< To: AMW
< To: AMMA

This is the AMW wiki FAQ.

Contents


What are the dependencies of AMW? Which are the other plugins that should be installed?

AMW depends on two plugins from ATL and AM3 plugins:

  • org.atl.eclipse.engine
  • org.atl.eclipse.km3

However, it is advisable to install all ATL and KM3 plugins, because AMW contains complex scenarios that use all the componentes of the AMMA platform, such as ATL transformations, or AM3 Ant Scripts.

Where can I find more information about the model management tasks used in AMW examples?

More information can be found in the AM3 Ant Tasks page.

Which version of AMW, AM3 and ATL should be installed to avoid version problems?

The required versions of the three plugins are mentioned in the corresponding download pages: AMW, AM3, ATL. <p/>

Why the menu "Extract ATL-0.2 model into ATL-0.2 file" does not appear when I try to extract an ATL model that was created from a weaving model?

Specific extraction and injection menus are available only in the "AM3 Resource Navigator", not in the "Package Explorer" view.