Difference between revisions of "AM3/How Install New AM3 From SVN"

From Eclipsepedia

< AM3
Jump to: navigation, search
(Updates according to AM3 SVN modifications)
Line 1: Line 1:
=Installation of the new AM3 (ATLAS MegaModel Management) prototype from SVN=
+
=Installation of the new AM3 (AtlanMod MegaModel Management) prototype from SVN=
  
 
==Install Eclipse, EMF, UML2 and ATL==
 
==Install Eclipse, EMF, UML2 and ATL==
  
In order to use all these AM3 plugins (ATLAS MegaModel Management), you need Eclipse, EMF, UML2 and ATL. These plugins have been tested with Eclipse 3.4, EMF 2.4, UML2 2.2 and ATL 2.1 (development branch). You can download Eclipse here: http://www.eclipse.org/downloads/, EMF here: http://www.eclipse.org/emf/ and UML2 here: http://www.eclipse.org/modeling/mdt/?project=uml2.
+
In order to use all these AM3 plugins (AtlanMod MegaModel Management) from the HEAD, you need Eclipse 3.5, EMF 2.5, UML2 2.3 and ATL 3.x. You can download Eclipse here: http://www.eclipse.org/downloads/, EMF here: http://www.eclipse.org/emf/ and UML2 here: http://www.eclipse.org/modeling/mdt/?project=uml2. You can install ATL3.x from [http://www.eclipse.org/modeling/m2m/downloads/index.php?project=atl "http://www.eclipse.org/modeling/m2m/downloads/index.php?project=atl"].  
  
You can install the compatible version of ATL from its sources by following the process explained in the [http://wiki.eclipse.org/ATL/How_Install_ATL_(Dev)_From_CVS "How Install ATL (Dev) From CVS" Wiki page]. Note that the current version of AM3 is not yet compatible with the latest ATL version (i.e. v3.0).
+
The plugins from the ''ATL 2.1 Compatibility'' branch have been tested with Eclipse 3.4, EMF 2.4, UML2 2.2 and ATL 2.1 (development branch). You can install the compatible version of ATL from its sources by following the process explained in the [http://wiki.eclipse.org/ATL/How_Install_ATL_(Dev)_From_CVS "How Install ATL (Dev) From CVS" Wiki page]. Note that this specific version of AM3 is not compatible with ATL 3.x and more.
  
 
==Configuration of SVN access==
 
==Configuration of SVN access==
Line 14: Line 14:
  
 
You do not need a password.
 
You do not need a password.
 +
 +
==SVN HEAD==
  
 
Then, you can go to '''plugins -> trunk'''. You can now select the projects as shown on the screenshot and check them out into your workspace (this action is available in the context menu).
 
Then, you can go to '''plugins -> trunk'''. You can now select the projects as shown on the screenshot and check them out into your workspace (this action is available in the context menu).
Line 19: Line 21:
 
[[Image:AM3new_SVNCheckout.PNG]]
 
[[Image:AM3new_SVNCheckout.PNG]]
  
==Configuration of AM3==
+
==SVN ''ATL 2.1 Compatibility'' Branch==
 +
 
 +
In that case, you have to go to '''plugins -> branches -> ATLv2_1_Compatibility'''. You can then select the projects as shown on the screenshot and check them out into your workspace (this action is available in the context menu).
 +
 
 +
[[Image:AM3_ATL_2_1_SVNCheckout.PNG]]
 +
 
 +
==Effective Launching of AM3==
  
 
Now, you need to go to the Plug-in perspective.
 
Now, you need to go to the Plug-in perspective.

Revision as of 10:31, 4 December 2009

Contents

Installation of the new AM3 (AtlanMod MegaModel Management) prototype from SVN

Install Eclipse, EMF, UML2 and ATL

In order to use all these AM3 plugins (AtlanMod MegaModel Management) from the HEAD, you need Eclipse 3.5, EMF 2.5, UML2 2.3 and ATL 3.x. You can download Eclipse here: http://www.eclipse.org/downloads/, EMF here: http://www.eclipse.org/emf/ and UML2 here: http://www.eclipse.org/modeling/mdt/?project=uml2. You can install ATL3.x from "http://www.eclipse.org/modeling/m2m/downloads/index.php?project=atl".

The plugins from the ATL 2.1 Compatibility branch have been tested with Eclipse 3.4, EMF 2.4, UML2 2.2 and ATL 2.1 (development branch). You can install the compatible version of ATL from its sources by following the process explained in the "How Install ATL (Dev) From CVS" Wiki page. Note that this specific version of AM3 is not compatible with ATL 3.x and more.

Configuration of SVN access

You should go to the SVN Repository view (you should first do Window -> Open Perspective in order to open the SVN Repository Exploring perspective). Then you should add a new repository location. The required parameters are the followings:

AM3 SVNRepositoryLocation.PNG

You do not need a password.

SVN HEAD

Then, you can go to plugins -> trunk. You can now select the projects as shown on the screenshot and check them out into your workspace (this action is available in the context menu).

AM3new SVNCheckout.PNG

SVN ATL 2.1 Compatibility Branch

In that case, you have to go to plugins -> branches -> ATLv2_1_Compatibility. You can then select the projects as shown on the screenshot and check them out into your workspace (this action is available in the context menu).

AM3 ATL 2 1 SVNCheckout.PNG

Effective Launching of AM3

Now, you need to go to the Plug-in perspective.

AM3 is ready to be tested. Just open the "Plug-in Development perspective" and launch a Run-time workbench (Click on Run -> Run as -> Run-time workbench).

You are ready to use the new AM3 prototype.