paratiel tools platform

Performance Tuning
and Analysis Tools

Objective

Become familiar with tools integrated with PTP, to help enhance
performance of parallel applications

Contents
Overview of ETFw and Performance Tools
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PTP/External Tools Framework

formerly “Performance Tools Framework”
G oa I | —<tool name="Valgrind">
| —<execute>

<utility comman
—<utility comman

+ Reduce the “eclipse plumbing”
necessary to integrate tools

</execute>
</tool>

+ Provide integration for
instrumentation, measurement, and
analysis for a variety of performance M
tools ~ rwsaraome | [

New_configurat

Build C, C++ or Fortran appl
programs from within Eclips

7 TAU| s

[-]

+ Dynamic Tool Definitions:
Wo rkfl OWS & U I d [] Build the instrumented executable but do not launch it

+ Tools and tool workflows are specified in an XML file

+ Tools are selected and configured in the launch
configuration window

+ Output is generated, managed and analyzed as

Profile

erformance analysis tools. Launch parallel

specified in the workflow E ]| W rvromer 5 ol (PSR ¢ [
+ One-click ‘launch’ functionality s | [FRElasan] o
+ Support for development tools such as TAU, PPW and " Perormance mna [leskchec =l ~shoeraschableyes

others. nemtest | | gk check

+ Adding new tools is much easier than developing a full EE
Eclipse plug-in
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SAX and JAXB Tool Definitions

Prior implementations of ETFW used a simple SAX
based schema to define tool workflows

By default workflows now use the more powerful
JAXB schema that defines PTP’s resource manager

Legacy workflows can still be loaded by selectmg the
SAX parser in PTP options

Window->Preferences-> e
Parallel Tools->External Tools

* Install/Update
> Java
¥ Parallel Tools
> Debug
* External Tools Restore Defaults Apply

@ cancel oK
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Performance Tuning
and Analysis Tools - TAU

+ Objective

+ Become familiar with tools integrated with PTP, to help
enhance performance of parallel applications

+ Contents

+ Performance Tuning and external tools:

+PTP External Tools Framework (ETFw), TAU
Hands-on exercise using TAU with PTP

TAU TAU-4
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TAU: Tuning and Analysis Utilities

+
+

+ + o+

+ +

TAU is a performance evaluation tool
It supports parallel profiling and tracing
+ Profiling shows you how much (total) time was spent in each routine

+ Tracing shows you when the events take place in each process along
a timeline

TAU uses a package called PDT (Performance Database Toolkit) for
automatic instrumentation of the source code

Profiling and tracing can measure time as well as hardware
performance counters from your CPU (or GPU!)

TAU can automatically instrument your source code (routines,
loops, I/O, memory, phases, etc.)

TAU runs on all HPC platforms and it is free (BSD style license)

TAU has instrumentation, measurement and analysis tools
+ paraprof is TAU’s 3D profile browser
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TAU Performance System Architecture
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PTP TAU plug-ins

http://www.cs.uoregon.edu/research/tau

+ TAU (Tuning and Analysis Utilities)
+ First implementation of External Tools Framework (ETFw)

+ Eclipse plug-ins wrap TAU functions, make them available
from Eclipse

+ Full GUI support for the TAU command line interface

+ Performance analysis integrated with development
environment

TAU TAU-7
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TAU Integration with PTP

+ TAU: Tuning and
A n a Iys I S U tl I itles 11::: ‘ * Selective instrumentation

* TAU stub makefile selection

* P e rf‘ ormance d a t a * TAU compiler options
collection and analysis
for HPC codes 0dCaon | bABl enionment variables

\ * TAU environment variables

+ Numerous features

* CO MMman d I I ne I nte rfa ce TATI trace data— tau_treemerge pl :|
tauZslog? = merged trace data
+ The TAU Workflow: L.
+ Instrumentation

+ Execution
+ Analysis

slog? file — jumpshot visnalization

TATI profile data — PerfDMF storage j
1

ParaProf visualizatior
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TAU PTP Installation

+ This tutorial assumes that the TAU extensions for PTP
are installed — they are not included in the
“Eclipse for Parallel Application Developers”

+ The installation section (Module 1) shows how to install
TAU and other features from the PTP update site -
be sure TAU was selected

To confirm:

+Help>Install New Software...
+Select the link "What is already
Workith: https//download.eclipse.org/tools/ptp/updates/kepler| v | Add. installed” at the bottom of the

Find more software by working with the "Available Software Sites" preferences.

Available Software

Check the items that you wish to install.

dialog

Name. — J e +You ;hould see the TAU
& 4+ PTP External Tools Framework TAU Extension 7.0.1.20130 EXte n S | O n

& * PTP External Tools Framework TAU Extension for Fortran 7.0.1.20130°
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Installing TAU Analysis Tools

+ The TAU plugin can use ParaProf for visual analysis and TauDB
for organization of profiles

+ To install these utilities on Mac or Linux platforms:

+ Download (browser, curl or wget)
tau.uoregon.edu/tautools.tgz

+ tar -zxf tautools.tgz
+ cd tautools-2.22.2
+ ./configure
+ Set path as shown (launch eclipse from this environment)
+ Run taudb_configure and follow the instructions
+ Java WebStart: tau.uoregon.edu/paraprof
+ TAU Installation, downloads and instructions: tau.uoregon.edu
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Assumptions

4+ Obtain and install TAU*

+ Download at tau.uoregon.edu
+ The website includes setup and user guides

+ Set up the $PATH on the remote machine*

+ For TAU you should be able to run ‘which pprof’ on a remote login
and see a result from your TAU bin directory

+ On trestles.sdsc.edu this is accomplished by loading the tau module
in the environment manager for the build and launch configurations

+ Include ‘eclipse.inc’ in the makefile*

+ Create an empty eclipse.inc file in the same directory as the
makefile

+ Place ‘include eclipse.inc’ in the makefile after regular compiler
definitions

+ ETFw will modify eclipse.inc to set CC/CXX/FC variables

TAU * SC tutorial: this has been done for you TAU-11
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Selective Instrumentation

+ By default tau provides timing data for each
subroutine of your application

+ Selective instrumentation allows you to
include/exclude code from analysis and control
additional analysis features

+ Include/exclude source files or routines

+ Add timers and phases around routines or arbitrary code
+ Instrument loops

+ Note that some instrumentation features require the PDT

+ Right click on calc.c, init.c, diag.c go to the Selective
Instrumention option and select Instrument Loops

+ Note the creation of tau.selective (refresh if needed)

TAU TAU-12
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Begin Profile Configuration

+ The ETFw uses the same run configurations and
resource managers as debugging/launching

+ Click on the '‘Run’ menu or the right side of the
Proﬂle button

+ From the dropdown menu select ‘Profile
configurations...’ -0 e le e | B0

8= 1 shallow-pbs-batch

I, copy  Profile As

>
HECIREYE  Profile Configurations... N

Organize Favorites...

TAU TAU-13
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Select Configuration

=N

e 552\

+ Select the shallow configuration Performance Analysis tab is
prepared earlier present in the Profile

+ The Resource and Application
configuration tabs require little or g
no modification ' .

+ We are using the same resource
manager and Torque settings

+ Since we are using a makefile project
the application will be rebuilt in and
run from the previously selected
location

Par: tion
&4 shallow-xsede13

View Script

Filter matched 4 of 4items

@

TAU

Configurations dialog

on| Parametric Study

du.sdsc.trestles.torque.batch

Description

The name assigned to the job by the qsub or qalter command.
Account to which to charge this job.
ST = | Designation of the queue to which to submit the job.

1:ppn=s Number and/or type of nodes to be reserved for exclusive use by the job.
[usage hint] number_nodes:ppn=N

Maximum amount of memory used by all concurrent processes in the job.
00:30:00 Maximum amount of real time during which the job can be in the running state
p—— = | Whichmpi command to use.
5 = the "-np' value [usually equals Nodes*ppn]
[ Allvariables inthe gsub command's environment are to be exported to the b:
Configure... Madules that will be loaded inside the job script.

View Configuration| | Restore Defaults

Revert
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Select Tool/Workflow

=

+ Select the Performance Analysis tab and
choose the TAU tool set in the ‘Select Tool’
dropdown box

+ Other tools may be available, either installed as
plug-ins or loaded from workflow definition XML files

+ Configuration sub-panes appear depending on the
selected tool

Tabs may be

hidden if the

window is too
small

TAU-15
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Select TAU Configuration

+ Choose the TAU Makefile tab/[i i u—

+ All TAU configurations in
remote installation are
available

4+ Check MPI and PDT
C h ec k b Oxes to fi Ite r I iste d & PAPI Select PAPI Counters | @ Preset Counters Native Counters
MELGIIES

+ Make your selection in the
Select Makefile: dropdown
0]0)7¢

+ Select Makefile.tau-mpi-pdt

& PDT PDT Instrumentation @ Compiler Instrumentation

Select Makefile: | Makefile.tau-openmpi-papi-mpi-pdt

TAU TAU-16
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Choose PAPI Hardware Counters

+ When a PAPI-enabled TAU
configuration is selected the PAPI |
Counter tool becomes available

+ Select the 'Select PAPI Counters’
button to open the tool

+ Open the PRESET subtree

+ Select PAPI_L1_DCM (Data cache
misses)

+ Scroll down to select PAPI_FP_INS
(Floating point instructions)

+ Invalid selections are automatically
excluded

+ Select OK
%D“)t available on trestles.sdsc.edu
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Compiler Options

+ TAU Compiler Options

+ Set arguments to TAU compiler scripts

+ Control instrumentation and
compilation behavior

+ Verbose shows activity of compiler
wrapper

+ KeepFiles retains instrumented source

+ PreProcess handles C type ifdefs in
fortran

+ In the Selective Instrumentation tab
select Internal then hit Apply

+ Scroll to bottom of the Tau Compiler tab
and activate TauSelectFile to use
tau.selective

TAU TAU-18
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Runtime Options

+ TAU Runtime options

+ Set environment variables used by
TAU

+ Control data collection behavior
+ Verbose provides debugging info

+ Callpath shows call stack
placement of events

+ Throttling reduces overhead
+ Tracing generates execution

Track memory headroom availability at

tl m eI i n e S function entry/exit with a context event

+ Set Profile Format to merged Hover help

TAU TAU-19
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Working with Profiles :

selected database

A text summary may be
printed to the console

Profiles may be uploaded to
the TAU Portal for viewing
online

+ tau.nic.uoregon.edu

Profiles may be copied to
your workspace and loaded
in ParaProf from the
command line. Select Keep |
Profiles

Submit Login Select a workspace

TAU Portal URL: https://tau.nic.uorege

Select Workspace: Testing

TA U Cancel Reset All
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Launch TAU Analysis

+ Once your TAU launch is
configured select ‘Profile’ ;
+ Notice that the project rebuilds W|th TAU compiler commands

+ The project will execute normally but TAU profiles will be generated

+ TAU profiles will be processed as specified in the launch
configuration.

+ If you have a local profile database the run will show up in the
Performance Data Management view

+ Double click the new entry to view in ParaProf
+ Right click on a function bar and select Show Source Code for
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Paraprof

+ Use ParaProf for profile visualization to identify
performance hotspots ——
+ Inefficient sequential computation I \
+ Communication overhead
+ I0/Memory bottlenecks
+ Load imbalance
+ Suboptimal cache performance

+ Compare multiple trials in PerfExplorer to identify
performance regressions and scaling issues

+ To use ParaProf, install TAU from tau.uoregon.edu or
use Java webstart from tau.uoregon.edu/paraprof

TAU TAU-22
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Exercise

+ Multi-Trial profile comparison

1.
2.
3.

(@)

TAU

Edit the shallow Makefile, adding -O3 to CFLAGS and FFLAGS
Rerun the analysis (Run->Profile Configurations. Hit Profile)
A second trial, distinguished by a new timestamp, will be
generated

+ It will appear in your Performance Data Manager view if a profile
database is available

+ Also present in the Profile subdirectory of your project directory

+ If you do not see a Profile directory right click on your project and go
to Synchronization->'Sync All Now'

Load the two trials in paraprof (on the command line: paraprof
/path/to/tauprofile.xml)

. Open Windows->ParaProf Manager
. Expand your database down to reveal all trials

Right click on each trial and click 'Add Mean to Comparison

Window' to visualize the two trials side by side
TAU-23
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