Jump to: navigation, search

STEM Installation Guide

(Redirected from Installation Guide)

STEM TOP BAR.gif

Back to STEM Contents Page

STEM Video on YouTubeTM

The STEM Project published full-length video tutorials for STEM on YouTube in several languages.

  1. Full length video In English
  2. Full length video In Hebrew
  3. Full length video In Japanese
  4. Full length video In Spanish
  5. 5 min Video (English)

Getting Started

There are two paths to running STEM: from a downloaded binary installed as a standalone application or built from source and launched in Eclipse. Here are some considerations regarding which path to choose:

  • If you want to use STEM to compose models, scenarios, and run simulations, you can download and install STEM as a standalone application following the instructions in this guide.
  • If you want to extend or add new functionality to STEM, including new disease and computational models, you need to build STEM from source. See the Setting up a STEM Development Environment page for more instructions.

Prerequisites

STEM is a Java application built on top of the Eclipse Rich Client Platform (RCP). To run STEM, please verify you have the following prerequisites installed:

  1. A workstation running an Eclipse-supported operating system:
    • Windows (XP, Vista, 7)
    • Linux (GTK)
    • Mac OS X (10.5 or later)
  2. A supported Java Standard Edition (J2SE) 6.0 JVM from either Oracle (Sun) or IBM (32-bit or 64-bit)
    Oracle Java SE 6.0 (6.0.26 or higher)
    IBM Java SE 6.0
    • Note: Mac OS X users can use the version included with the operating system
    • Note: The GNU for Java (GCJ) compiler and libraries are not supported. If you're running on Linux, it's strongly recommended you use an Oracle or IBM JRE
    • Note: While STEM should work with Java 7, it is not tested or supported at this time
  3. A tool to extract zipped archives
    Most operating systems have this built-in, although Windows users may wish to install a standalone utility like 7-Zip

Which File To Download?

The STEM Project publishes several different binary versions of the application. Please consider these options when choosing which to download.

32-bit vs. 64-bit

Most modern operating systems from 2009 and on support 64-bit (x86_64) compiled binaries. The 64-bit version of STEM can take advantage of larger memory spaces (beyond 2 GB), which is necessary to run very large (global) simulations.

The STEM project publishes both 32-bit (x86) and 64-bit (x86_64) versions of the application for each supported operating system. The version you download strictly depends on whether you have a 32-bit or 64-bit Java Runtime Environment (JRE) installed. If you have a 64-bit JRE installed, download the x86_64 version. Otherwise, download the x86 version.

Some 64-bit JREs can run in 32-bit mode. Please see your JRE's documentation for instructions.

Release, Milestone, or Integration Builds

The best version of STEM to download is generally the latest Release. In addition to being fully tested and stable, it's approved for distribution by the Eclipse Foundation and subject to the terms of the Eclipse Software User Agreement and the Eclipse Public License.

However, power users or those looking for the latest features may choose to download the latest Weekly Integration, Milestone, or Release Candidate build. These builds may not be stable and are not sanctioned by the Eclipse Foundation. Use at your own risk.

Downloading and Installing STEM

The STEM application is bundled as a platform-specific, zipped archive and does not contain an installer. To install STEM, download the appropriate bundle and unzip it to your desired installation path.

The STEM installation path cannot contain whitespace characters. Ensure that the install path contains no spaces, tabs, etc.

If you already have STEM 1.4 or newer installed and wish to upgrade, see the STEM Updates section.

  1. In your browser, go to the STEM Downloads page
  2. Choose the appropriate bundle to download (see previous section for help) and click the link
  3. On the mirrors page, select a nearby mirror site. This will begin the download.
  4. If prompted, choose to Save the file. Note where the file is downloading to.
    On some systems, the browser may automatically execute (unzip) the file when it finishes downloading. If this is the case, skip to step 8 when the download finishes.
  5. Wait while the STEM bundle downloads...
    Note: STEM is approximately 150 MB in size. Depending on your connection and mirror speeds, the download will take from a few minutes to an hour or more.
  6. When the download finishes, open the folder where the downloaded file sits
  7. Extract/unzip the STEM archive
    Note: On most systems, double clicking the the .zip file will automatically extract it.
  8. Extracting the archive should create a folder called stem. Move this folder to the path you wish to install STEM at.
    IMPORTANT REMINDER: Verify that the install path does not contain whitespace or non-ASCII characters, including spaces, tabs, etc.
    • Windows users may want to place stem folder in a drive root. Example is c:\stem
    • Mac OS X users may want to place the stem folder in the Applications folder
  9. Optionally, you can create a shortcut on your desktop, start menu, dock, etc to quickly launch STEM

That's it! STEM is now installed. See the next section for instructions to launch STEM.

Launching and Running STEM

After STEM is unzipped and placed in the install folder, you can launch the application. STEM can run both with a full Graphical User Interface (GUI) or "headlessly" in a text-only console. For more information about the text-only option, see the headless STEM article.

  1. Navigate to the folder STEM is installed in
  2. Double click the STEM executable file
    STEM-Install-FinderView.png
    • For Windows, the file is named STEM.exe
    • For Mac OS X, the file is named STEM or STEM.app
    • For Linux, the file is named STEM
  3. On some system, you may get a security warning about launching a downloaded application. Click OK or Open
    Note: This warning message varies depending on your operating system
    STEM-Install-DownloadedApplicationWarning.png
  4. The STEM splash screen should immediately appear
    STEM-Install-Splash.png
  5. The first time STEM is launched, several configuration tasks have to run in the background
    These tasks may take 1-2 minutes depending on system speed. During this time, only the splash screen is displayed.
  6. When STEM finishes loading, the workbench will launch the Simulation perspective
    The first time you run STEM, the Welcome to STEM screen will display. You can close this by click the X on the Welcome tab.
    STEM-Install-WelcomeScreen.png
  7. Congratulations! STEM is loaded and ready to use
    STEM-Install-Workbench.png
  8. To get started using STEM, start by going through the tutorials on the STEM Documentation page
    You may find it helpful to watch the YouTube tutorial before you go on to learn to create a scenario

Installing Additional STEM Features

See section on STEM Add-ons

STEM uses the Automated Eclipse Updates to make it easier for users to install additional features to STEM. Today, one feature you may want to add is the Earth Science data plugin that contains global climate data for the years 2001-2010. This plugin is required, for example, if you want to use the Anopheles Mosquito model.

See the main article for instructions on how to install new features into STEM.

Updating STEM

Starting with version 1.4, you can use the update mechanism built into STEM to perform upgrades without re-downloading the full installation bundle. Most of the time, this means you don't have to re-download the large denominator data sets packaged in STEM or have to export and import your scenarios.

  1. Verify the computer is connected to a network and launch STEM
    If STEM is already open, save all edited files and stop any running simulations
  2. Open the Help Menu and choose Check for Updates
    STEM-Update-CheckForUpdatesMenu.png
  3. Wait while STEM contacts the updates server and checks for new versions
    • If no updates are available, a message saying No updates were found will appear. Click OK to return to STEM
    • If an update is available, the Available Updates wizard will appear
  4. On the Available Updates page, verify STEM is selected, and click Next
    STEM-Update-AvailableUpdates.png
  5. Verify the list of items to be installed is correct and click Next
  6. Review the the licenses of the software being installed to verify you still accept
    If you accept the terms, select I Accept the terms of the license agreements and click Finish
    If you do not accept the terms, click Cancel
  7. Wait while STEM downloads and installs the updates
  8. If prompted with a security warning about installing unsigned software, click OK
  9. When prompted to apply changes, verify all open files are saved and click Restart Now
  10. STEM should automatically restart. If not, relaunch it manually

Checking the Version of STEM Installed

After updating STEM, the version displayed on the splash screen at startup may not change to reflect the new version. To verify STEM updated successfully, check the STEM Installation Details.

  1. Open the Help menu and select About STEM
  2. Click Installation Details
  3. In the STEM Installation Details dialog, verify the installed version for STEM
    STEM-Update-InstalledDetailsVersion.png

Updating to Latest Integration or Milestone Build

By default, the STEM update feature only checks for the latest, official release approved by the Eclipse Foundation. However, users will often want to take advantage of new features published in weekly integration and/or periodic milestone and release candidate builds. You can easily configure STEM to download and install these updates.

  1. Launch STEM
  2. Open the Window menu and select Preferences
    On Mac OS X, Preferences is under the STEM menu
  3. In the Preferences window, expand Install/Update and select Available Software Sites
  4. Under Available Software Sites, click Add
  5. In the Add Site dialog, enter the appropriate Name and Location
    For weekly integration builds:
    • Name: STEM Integration Builds
    • Location: http://download.eclipse.org/stem/update-site/integration/
    For periodic milestone and release candidate builds:
    • Name: STEM Stable Builds
    • Location: http://download.eclipse.org/stem/update-site/stable/
  6. Click OK to add the site
  7. Click OK to save Preferences and return to STEM
  8. Follow the steps in the previous section to update STEM
  9. To disable checking for non-release versions, disable or remove the sites added to the Available Software Sites list

Setting up the STEM Development Environment in Eclipse

If you might contribute to STEM development or if you want to always have the most recent code, then you will need to install Eclipse.

Go to tutorial on Setting up a STEM Development Environment