Jump to: navigation, search

EMFIncQuery/UserDocumentation/GettingStarted

Installing EMF-IncQuery

Dependencies

EMF-IncQuery depends on recent version of Xtext/Xtend.

Xtext 2.3 Xtext 2.4 Xtext 2.5 Xtext 2.6
EMF-IncQuery 0.7 Compatibility branch Yes No No
EMF-IncQuery 0.8 No Runtime only Runtime only* Yes

Remarks:

  • The codebase of EMF-IncQuery 0.8 is compatible with Xtext 2.5, but its editor components needs to be regenerated. To avoid confusion, the code base states it requires Xtext 2.6; but it can trivially be updated to work with 2.5 (after a regeneration of editor).

Installation

The main update site provides both the EMF-IncQuery runtime and the query development extensions for Eclipse. It is recommended to install as few features directly as needed, rely on the p2 installer to download required features:

  • Select the EMF-IncQuery SDK feature
  • If you want to use IncQuery with Graphiti or GMF, select the features GMF Support for EMF-IncQuery or Graphiti Support for EMF-IncQuery, respectively

Additional features

  • Rete visualizer - experimental as of the GEF/GEF4 Zest dependency
  • Zest graph support for Viewers framework - experimental as of the GEF/GEF4 Zest dependency

Additionally, this update site contains the latest GEF4 Zest to ease the installation. Because of the frequent changes in GEF4 Zest, the graph viewer components are only tested with this bundled version of Zest - other versions may or may not work.

First steps

The built-in cheat sheet should help you with the first steps. We also maintain a web-based tutorial. Additionally, you can check the School and BPMN introductory walkthrough examples to help you get started.

Examples

We have a list of examples available in EMFIncQuery/UserDocumentation/Examples.