Jump to: navigation, search

DTP project meeting, January 18, 2012

Back to DTP Meetings, 2012 page


Attendees

  • Linda Chan (Actuate)
  • Brian "Fitz" Fitzpatrick (Red Hat)
  • Brian Payton (IBM)

Minutes

  • Welcome back Fitz!
  • We took a look at bugs 368412 and 368695, which are in the Connectivity in-box. Fitz will commit 368695 (from Pierre Quiennec), but 368412 is actually an Enablement fix. We changed the in-box assignment and Brian P. will look into it (since it affect IBM databases).
  • Brian P. fixed various plugin version issues identified by the Build team's automated version checking tool. There are a couple of warnings related to .cvs to .git changes (that is, build environment changes rather than code changes). These could be filtered out of the tool results, but would that prevent real problems in the future going unreported? Linda will check with the Build team to see how smart (specific) the filtering is.
  • Linda will add the 1.10 release number to Bugzilla.
  • Linda added the 1.9.2 New and Noteworthy section of the DTP wiki page.
  • Should we move the DTP 1.10 build to build on the Eclipse 3.7 platform? Our usual policy is to build on the "previous" Eclipse release, which for Juno will be Indigo (3.7). Brian P. said that he would prefer that we keep building on DTP 3.6.2. Linda pointed out that the current Indigo release is 3.7.1, but 3.7.2 will be out soon. We decided to leave things as they are (3.6.2) for now.
  • Linda said that there's nothing going on with the DTP Incubator, so why bother building it? We decided to continue building it for 1.9.2 but not build it for 1.10. Linda will put a notice in the wiki info for the Incubator project about this.
  • JDK 1.6: we understand what's going on with the builds a bit better now. The Build team is set up to build with either Java 5 or Java 6. Individual plugins can specify their JDK requirement. (We set our Connectivity plugin that implements JDBC interfaces to JDK 1.5, for example.) If you build with 1.6, then you need to have the libraries for both 1.5 and 1.6 on your build path. Currently, we don't have any plugin that specifically requires 1.6, so you can build everything with 1.5. Linda will ask the Build team to switch to using Java 6 for the build as the default Java.