Building the Embedded-Selector Extension for Firefox

From Eclipsepedia

Jump to: navigation, search

Higgins logo 76Wx100H.jpg

Contents

Prerequisites

This guide assumes you have the following software:

Set up your Eclipse workspace

Open a blank workspace

After you start Eclipse, it should display a blank workspace. If you have already been working in Eclipse and your workspace is not empty, you can create a new empty one by selecting File -> Switch Workspace -> Other. Select a folder to use for your new, blank workspace.

Your workspace should look like this:

File:Saml2idp-setup1.png
Blank Eclipse workspace

Make sure your blank workspace is configured to build all projects automatically:

Build Automatically

Configure JDK

You should configure your Eclipse IDE to use JDK instead of JRE in order to be able to use Java compiler from ant scripts to build the Higgins components. Click Window -> Preferences and select Java -> Installed JREs. The default JRE is the one that was used to launch Eclipse, however you need to add a different one and set it as the workspace-default one for building. Higgins components are usually built with a Java 1.4 compiler.

Configure JRE

Note: You should also check Java -> Compiler -> Compiler compliance level, and make sure this matches the JRE you use to build the projects.

Check out main project

First of all import org.eclipse.higgins.hbx project into workspace, click File -> Import. In the import source list, select Other -> Checkout Projects from SVN. The URL for connecting to the Eclipse SVN is as follows:

https://dev.eclipse.org/svnroot/technology

Checkout org.eclipse.higgins.hbx project from https://dev.eclipse.org/svnroot/technology/org.eclipse.higgins/trunk/app/org.eclipse.higgins.hbx/

Note: This may take several minutes, depending on your internet connection and current Eclipse server load.

Building

Next, unfold org.eclipse.higgins.hbx-project contents in Package Explorer, choose in the project tree “*\org.eclipse.higgins.hbx\firefox\bx\XPCom\build.xml and push the right mouse button (if this file already opened, push the right mouse button on the edit area). In popup menu choose item Run AS->Ant Build.

Choose popup menu item

On the first step, that script makes folder “build” in the directory “*\org.eclipse.higgins.hbx\firefox\bx\XPCom”. Into this folder making subfolders subfolder “bin” and “xpi”. On the second step script executing, needed files will be copied from base folder into folder "bin". Next, script makes jar-file “higginsbx” in folder bin/chrome. Then script makes “.xpi” archive and copies it into “*\org.eclipse.higgins.hbx\firefox\bx\XPCom\build\xpi” folder.

As result, the folder *\org.eclipse.higgins.hbx\firefox\bx\XPCom\build\xpi will contain “higgins.xpi”.